Barracuda Backup Service web interface is having intermittent issues loading

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Jan 16, 2026 - 20:37 UTC

Monitoring

We've identified the problem, implemented a fix, and are monitoring the results.
Posted Jan 16, 2026 - 19:48 UTC

Investigating

Our team is investigating reports of intermittent issues loading the Barracuda Backup Service web interface.
Posted Jan 16, 2026 - 16:48 UTC
This incident affected: Backup Service (Web Interface).