Email Gateway Defense (US) - Slow or unsuccessful message log UI loading

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Mar 08, 2025 - 13:09 UTC

Monitoring

We have implemented a fix for the issue and are monitoring the results of that change.
Posted Mar 07, 2025 - 22:05 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 07, 2025 - 21:37 UTC

Identified

A subset of customers are experiencing slow or unsuccessful loading of the Email Gateway Defense message log. We have identified the source of the issue and are working towards resolution.
Posted Mar 07, 2025 - 21:21 UTC
This incident affected: Email Gateway Defense (User Interface).