The infrastructure is back to stable condition - the team is working on identifying the cause of the incident and detailed RCA.
Posted Jul 30, 2026 - 12:51 UTC
Verifying
The remediation measures have been initiated and the applications have started to stabilize. We will continue to monitor for any anomalies and ensure traffic latencies are resolved completely within the next few minutes.
Posted Jul 30, 2026 - 12:25 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 30, 2026 - 12:05 UTC
Scheduled
WAF-as-a-Service will be undergoing a scheduled maintenance for reverting the recent changes pushed as part of the window, as they are causing latencies with applications hosted in certain regions. We are expecting no downtime or impact to traffic processing or log propagation during this maintenance.
Posted Jul 30, 2026 - 12:02 UTC
This scheduled maintenance affected: WAF-as-a-Service (Traffic Processing).