Email Gateway Defense: users receiving invalid login errors
Incident Report for Barracuda Networks
Monitoring
Email Gateway Defense: We’re gradually rolling out the enhanced authentication with new user interface. You can learn more about enhanced authentication here: https://campus.barracuda.com/doc/100368461/ and our new User Interface for end users here: https://campus.barracuda.com/doc/96023030/
Posted Sep 15, 2023 - 16:23 UTC
Update
We sincerely appreciate your patience during the recent invalid login issues. We are thrilled to share a promising update: the complete long-term solution is currently in testing. We anticipate starting beta testing by week's end, with a full rollout targeted by month-end. If you are still experiencing issues with logging in, our customer support team has several work-arounds available that can be quickly implemented at your request.

Your understanding and support mean a lot to us as we work towards a seamless experience.
Posted Aug 09, 2023 - 21:16 UTC
Update
We want to express our gratitude for your understanding and patience as we worked to address the recent invalid login errors on our Email Gateway Defense product.
The temporary workaround is now in place since July 20th, providing relief from the issue for most users. If you are still experiencing issues with logging in, our customer support team has several work-arounds available that can be quickly implemented at your request.
Nevertheless, our team continues to diligently work on a long-term solution. We aim to provide an update during the week of 8th August, ensuring a smoother experience for you. If you have any questions or concerns, please don't hesitate to reach out to our support team.
Posted Aug 02, 2023 - 21:22 UTC
Update
Some customers of Email Gateway Defense (formerly “Essentials”) may be encountering intermittent issues with logging into the end-user interface to perform actions such as reviewing quarantined messages. End-users are presented with an “invalid login” error. Administrator access to the product is unaffected in all cases.

While we work diligently on implementing a resolution to the issue, our customer support team has several work-arounds available that can be quickly implemented at your request.

Our aim is to implement a temporary solution, where a user will be redirected to a working UI on Monday the 24th of July or sooner. The full solution will be implemented by end of month, where we will eliminate all login issues.

Thank you for your understanding and patience as we work to improve your experience with our product. We are committed to providing you with the best product and service possible.

If you have any questions or concerns, please don't hesitate to reach out to our support team.
Posted Jul 20, 2023 - 20:49 UTC
Identified
The fix that was deployed has not completely resolved the issue of invalid login errors that our users on Email Gateway Defense are currently experiencing. The team is diligently continuing to work on this matter, prioritizing its resolution. We are actively investigating the root cause and implementing additional measures to ensure a comprehensive solution.

We understand the frustration this may be causing and want to assure you that addressing this problem remains our top priority. We apologize for any inconvenience it may have caused and sincerely appreciate your ongoing patience and support as we work through this challenging situation.

Rest assured, we are committed to providing a secure and seamless experience for all our users, and we will keep you informed of any significant updates. Please do not hesitate to reach out to our support team if you have any questions or concerns.
Posted Jul 17, 2023 - 23:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2023 - 23:09 UTC
Identified
Users on Email Gateway Defense are receiving an error: The link to login is invalid. We are investigating login problems seen by users and have identified the problem. We are working on fixing the issue with a tentative timeline for the fix to be released on or before July 14th. We thank you for your understanding and support as we work through this issue and sincerely apologize for any inconvenience it may cause. If you have any questions, please reach out to support@barracuda.com.
Posted Jul 06, 2023 - 20:24 UTC
This incident affects: Email Gateway Defense (User Interface).