Barracuda MSP Performance Degradation in the Americas region
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Mar 09, 2024 - 18:39 UTC
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Mar 09, 2024 - 17:44 UTC
Identified
The issue has been identified, and a fix is being implemented.
Posted Mar 09, 2024 - 17:30 UTC
Investigating
We are currently investigating the issue impacting the following services in the Americas region.

• ECHOplatform portal
• MSP App
• Scheduled Backup and Restore services
• Barracuda API access
Posted Mar 09, 2024 - 16:38 UTC
This incident affected: ECHOplatform.