Emails re-scanned and re-processed on Email Gateway Defense (EGD) due to spam scoring logic correction
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jul 06, 2023 - 18:59 UTC
Monitoring
As previously indicated, at approximately 15:09pm UTC on May 22, 2023, a routine update to Email Gateway Defense's (EGD) spam scoring logic inadvertently caused customers' email scores to be increased by 2.9 points. This unfortunately led to a significant amount of email messages to be blocked as false positives. The spam rule update was reverted, however a large number of users needed to sign onto EGD redeliver their incorrectly blocked messages.
Since then, Barracuda has worked to re-scan and re-process all emails that were incorrectly blocked (false positives), with the exception of emails where customers have since taken their own subsequent actions such as redelivery, deletion, etc. Our re-processing procedure, with these noted omissions, has now completed. If customers believe that our corrective actions have not fully resolved this issue, they are requested to contact Barracuda Customer Support. Again, we apologize for the inconvenience this issue has caused.
Posted May 29, 2023 - 23:42 UTC