PST imports/exports slow processing in US Region
Incident Report for Barracuda Networks
Resolved
We have resolved the issue. PST processing has returned to normal speed and the previously mentioned backlog is nearly clear. We are monitoring to ensure the issue does recur. If you notice further processing issues, please reach out to the support team.
Posted Dec 07, 2021 - 15:02 UTC
Identified
Our engineering team has identified the issue and has begun efforts to resolve it. PST processing is returning to normal speed, though a backlog has accumulated that may take several days to clear. We appreciate your patience.

We will provide another update as the backlog processes.
Posted Dec 01, 2021 - 21:44 UTC
Investigating
We have identified delayed processing for PST imports and exports in the US region. The Engineering team is investigating the issue.
Posted Nov 30, 2021 - 20:24 UTC
This incident affected: Cloud Archiving Service (PST Import).