Barracuda Cloud Archiving (BCAS) - Mail Flow and Activation Down in the US Region

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Jan 27, 2025 - 22:35 UTC

Investigating

Mail flow and activation down in the US Region. We are currently investigating the issue. There is no concern of data loss at this time, but you may see journaling queues filling up.
Posted Jan 27, 2025 - 20:39 UTC
This incident affected: Cloud Archiving Service (Mail Processing).