EU DC failing journaling and exchange actions across multiple tenants
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Feb 12, 2021 - 17:22 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 25, 2021 - 21:37 UTC
Monitoring
A fix has been implemented and we continue to monitor the backlog of messages.
Posted Jan 22, 2021 - 18:33 UTC
Update
We are continuing to investigate this issue.
Posted Jan 22, 2021 - 07:32 UTC
Update
We are continuing to investigate this issue.
Posted Jan 22, 2021 - 07:18 UTC
Update
We are continuing to investigate this issue.
Posted Jan 22, 2021 - 07:13 UTC
Update
We are continuing to investigate this issue.
Posted Jan 22, 2021 - 07:11 UTC
Update
We are continuing to investigate this issue.
Posted Jan 22, 2021 - 07:04 UTC
Investigating
BCAS is currently experiencing an issue with delayed mail processing . Our engineers are currently working to identify the cause and get our services back online. We understand this has impacts on your business, we are working to get you up and running as fast as possible.

We will provide another update once the issue has been identified and we have started to implement a solution.
Posted Jan 22, 2021 - 07:03 UTC
This incident affected: Cloud Archiving Service (Mail Processing).