Delayed processing of email threats & remediations
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jan 16, 2025 - 13:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 15, 2025 - 20:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 15, 2025 - 17:25 UTC
Investigating
A subset of customers are experiencing delays remediating threats and searching for emails. We are currently investigating this issue.
Posted Jan 15, 2025 - 17:09 UTC
This incident affected: Impersonation Protection (formerly Sentinel) (Email Processing) and Incident Response (Dashboard UI, Email Processing).