Delayed Mail Processing in View

Incident Report for Barracuda Networks

Resolved

This incident has been resolved. There is no delay in processing at this time and systems are back to normal.
Posted Dec 05, 2025 - 19:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 04, 2025 - 19:17 UTC

Update

We are investigating an issue that is affecting journaling in the EMEA and APAC regions. Email journaling may be delayed by this issue. If you have detected a build up in journal queues, we appreciate your patience as we work to collect those emails.
Posted Dec 04, 2025 - 15:53 UTC

Investigating

Partners and end customers in the EU and AU regions may see delays in processing mail.
Posted Dec 04, 2025 - 15:30 UTC
This incident affected: View - Cloud Email Archive (EMEA | nest1-view-eu | viewarchive.co.uk, APAC | nest1-view-au | au.viewarchive.com).