Microsoft 365 mail delivery delays

Incident Report for Barracuda Networks

Monitoring

Barracuda Networks is aware of reports of deferred email deliveries to Microsoft 365 (Exchange Online). Microsoft is currently returning a temporary error on inbound connections. Messages are queued by the sender's mail servers and will be retried automatically. Once Microsoft's service recovers, the messages should be delivered—no action needed from you. We're monitoring and will update when normal delivery resume. Status on Microsoft: status.cloud.microsoft
Posted Jan 22, 2026 - 19:50 UTC

Investigating

We're seeing deferred email deliveries to Microsoft 365 (Exchange Online). Microsoft is returning a temporary error on inbound connections. Messages are queued by the sender's mail servers and will be retried automatically. Once Microsoft's service recovers, the messages should be delivered—no action needed from you. We're monitoring and will update when normal delivery resumes. More info on Microsoft global status: status.cloud.microsoft
Posted Jan 22, 2026 - 19:49 UTC
This incident affects: Email Gateway Defense (Mail Delivery).