Barracuda Cloud Archiving (BCAS) Maintenance - Power Outage in US Data Center

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 15:43 UTC

Update

We are continuing to monitor for any further issues.
Posted Jan 31, 2025 - 21:09 UTC

Monitoring

We have been notified of a power outage in our US data center which has impacted some US customers. Power has been restored and systems are rebooting now. Searching and indexing are affected, but journaling is not so there will be no data loss. We will continue to monitor until all systems are back to full functionality.
Posted Jan 31, 2025 - 15:18 UTC
This incident affected: Cloud Archiving Service (Web Interface, End-user Access, Mail Processing).