Barracuda Cloud Archiving (BCAS) - Mail Processing Delayed in EU Region

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 12:45 UTC

Update

Thank you for your patience as the delayed mail backlog processes. We will continue to monitor the situation until the queue has fully recovered.
Posted Apr 08, 2025 - 16:29 UTC

Monitoring

A fix has been implemented and we are monitoring results. Thank you for your patience as the delayed mail backlog processes.
Posted Apr 07, 2025 - 16:55 UTC

Investigating

Mail processing is significantly delayed in the EU region. Mail is still being journaled, but there are long waits before the mail appears in the archive. We are currently investigating the issue.
Posted Apr 07, 2025 - 13:24 UTC
This incident affected: Cloud Archiving Service (Mail Processing).