BCAS Mail Processing Delays in APAC

Incident Report for Barracuda Networks

Resolved

The mail processing delays have been resolved and normal mail flow has resumed.
Posted Nov 03, 2025 - 15:57 UTC

Monitoring

A fix has been implemented and mail flow is being monitored. We may continue to see some delays in mail processing.
Posted Nov 03, 2025 - 06:11 UTC

Identified

BCAS is currently experiencing mail processing delays in the APAC region.
Posted Nov 03, 2025 - 04:36 UTC
This incident affected: Cloud Archiving Service (Mail Processing).