Barracuda Cloud Archiving Service (BCAS) - US Region - Web Availability
Incident Report for Barracuda Networks
Resolved
Monitoring has confirmed successful restoration of service.
Posted Dec 21, 2024 - 06:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 21, 2024 - 05:56 UTC
Update
We have identified the issue and a fix is in place.
Posted Dec 21, 2024 - 05:56 UTC
Investigating
We are aware of impact to the UI in the US Region are investigating. Mailflow and other services are not impacted at this time.
Posted Dec 21, 2024 - 05:16 UTC
This incident affected: Cloud Archiving Service (Web Interface).