Barracuda Cloud Archiving (BCAS) - Service Degradation

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 13:46 UTC

Identified

BCAS is currently experiencing an issue resulting from an AWS outage that is impacting our services. Our engineers are currently working with AWS to get our services back online. We understand this has an impact on your business, and we are working to get you up and running as quickly as possible.
Posted Oct 20, 2025 - 15:40 UTC
This incident affected: Cloud Archiving Service (Web Interface, End-user Access, Mail Processing, Exchange Integration, PST Import, Retention).