Barracuda XDR - Service Disruption

Incident Report for Barracuda Networks

Resolved

This incident has been resolved, and the events ingestion service is fully operational
Posted Jul 17, 2025 - 02:57 UTC

Identified

Barracuda XDR is currently experiencing an issue in the events ingestion process, only in US region, which could result in delayed ingestion. Our engineers have identified the cause and are currently working on resolving this service issue. We understand the impact this may have on your business and are committed to restoring full functionality as quickly as possible.
We will provide further updates as we identify the root cause and implement a solution.
Posted Jul 16, 2025 - 23:01 UTC
This incident affected: XDR (XDR Service).