BCAS degraded Search Performance in UK region

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 19:05 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 20, 2025 - 14:56 UTC

Monitoring

Our Engineering team identified degraded search performance in the UK region and has applied the fix. We will continue to monitor the situation.
Posted Mar 20, 2025 - 14:50 UTC
This incident affected: Cloud Archiving Service (Web Interface).