Impersonation Protection & Incident Response - Service Degradation

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 01:00 UTC

Identified

We are investigating an issue that is affecting Impersonation Protection and Incident Response in the US region. There may be delays in mail processing until this is resolved.
Posted Oct 20, 2025 - 12:04 UTC
This incident affected: Impersonation Protection (formerly Sentinel) (Email Processing) and Incident Response (Email Processing).