Barracuda Cloud Archive Service Mail Processing - Delayed SMTP Journaling in US Region

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 17:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2025 - 20:31 UTC

Identified

We have identified an issue that is affecting Barracuda Cloud Archiving Service customers in the US region. We are working to resolve the issue. Email processing may be delayed or interrupted by this issue.
Posted Sep 04, 2025 - 19:24 UTC
This incident affected: Cloud Archiving Service (Mail Processing).