Degraded Performance for ESS, BATP
Incident Report for Barracuda Networks
Postmortem

Temporary Connectivity Issues with European ATP Cloud

Summary: On May 16th 2018, 11:45 am CET, an unexpected upstream carrier maintenance update lead to temporary connectivity issues and delays for pending file analysis tasks in one of our European datacenters. Unfortunately, also the automatic failover to other ATP instances was affected by this issue and did not work seamlessly. As a result, some Firewall devices were no longer able to dispatch files for cloud emulation.

Mitigation: May 16th, 2018, 13:30 PM CET - After thorough investigations the Barracuda Operations Team was able to pinpoint and remediate the error.

We apologize for any inconvenience caused by this issue. We are constantly evaluating our quality assurance and operations processes and took appropriate measures to immunize our systems against similar incidents in the future.

Posted May 23, 2018 - 13:14 UTC

Resolved
This incident has been resolved.
Posted May 16, 2018 - 14:35 UTC
Update
We are continuing to monitor for any further issues.
Posted May 16, 2018 - 14:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 16, 2018 - 14:07 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 16, 2018 - 12:45 UTC
Investigating
We are looking into a problem causing degraded performance for ESS in the US region and BATP in the EU.
Posted May 16, 2018 - 11:40 UTC
This incident affected: CloudGen Firewall (Advanced Threat Protection) and Email Gateway Defense (Mail Delivery).