Email Gateway Defense - Classic UI Degraded Performance in the US region

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Mar 13, 2025 - 16:56 UTC

Monitoring

A fix has been implemented and we're currently monitoring.
Posted Mar 13, 2025 - 14:25 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 13, 2025 - 14:20 UTC

Investigating

The classic UI in the US region is currently experiencing degraded performance for both admin and user message log. Mailflow is unaffected, we're actively investigating the issue.
Posted Mar 13, 2025 - 14:07 UTC
This incident affected: Email Gateway Defense (User Interface).