Barracuda XDR – Dashboard datasource visibility issue

Incident Report for Barracuda Networks

Resolved

This incident has been resolved, and the visibility of data sources within the XDR dashboard (CSD) is now fully operational
Posted Mar 30, 2026 - 14:48 UTC

Monitoring

We have successfully implemented a solution to address the data source visibility issue within the XDR Dashboard. We will continue to monitor the system to ensure it is fully operational.
Posted Mar 30, 2026 - 14:13 UTC

Identified

Barracuda XDR is currently experiencing an issue affecting the visibility of data sources within the XDR dashboard (CSD). As a result, log degradation alerts generated from March 28 may be false positives. The data sources impacted include Windows and certain firewall integrations. Our engineering team has identified the root cause as a failure in the API call to the datalake and is actively working to resolve the issue.
We acknowledge the potential impact this may have on your business operations and remain fully committed to restoring full functionality as quickly as possible. We would also like to confirm that there is no impact to event ingestion or signal detection within the XDR platform.
Posted Mar 30, 2026 - 11:49 UTC
This incident affected: XDR (XDR Dashboard).