Customers Unable to Authenticate to BCC

Incident Report for Barracuda Networks

Postmortem

An authentication change was rolled back that caused some user logins to fail. The issue has been identified and resolved.

Posted Jun 04, 2025 - 17:16 UTC

Resolved

Per support the issue is resolved with the rollback. Barracuda will continue to monitor.
Posted Jun 04, 2025 - 17:11 UTC

Monitoring

Some customers logging into BCC were receiving "User credentials were invalid, please try again" error due to a bug in a latest version release. Rollback has taken place to resolve the problem.
Posted Jun 04, 2025 - 17:08 UTC
This incident affected: Cloud Control.