Barracuda Backup (BBS) - Degraded Cloud Replication Performance (Canada Region)
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Mar 25, 2023 - 16:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2023 - 19:43 UTC
Investigating
We are currently investigating this issue.
Posted Mar 24, 2023 - 13:01 UTC
This incident affected: Backup Service (Offsite Transfers).