Authentication Services Issue Affecting Some Customers

Incident Report for Barracuda Networks

Resolved

We have resolved an issue that was affecting some Authentication Services customers.
Posted Jul 31, 2026 - 18:02 UTC

Update

We are continuing to investigate this issue.
Posted Jul 31, 2026 - 18:02 UTC

Investigating

We have identified an issue that may be affecting some Authentication Services customers specifically around the "Login with Microsoft Button". Authentication services functionality may be affected by this issue.
Posted Jul 31, 2026 - 17:36 UTC
This incident affected: Authentication Services.