Email Gateway Defense - US Region - Degraded performance with ALL user interfaces.
Incident Report for Barracuda Networks
Resolved
This issue has been resolved.
Posted Dec 02, 2024 - 22:13 UTC
Monitoring
A fix has been implemented and we're currently monitoring the health of the UI.
Posted Dec 02, 2024 - 18:31 UTC
Investigating
We are experiencing greater than usual response times for all user interfaces in the US region. We are currently investigating the problem. This problem currently impacts US customers only.
Posted Dec 02, 2024 - 17:45 UTC
This incident affected: Email Gateway Defense (User Interface).