Barracuda Backup Service web interface is unreachable.

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 22:56 UTC

Monitoring

The issue has been identified, a fix has been implemented, and we're monitoring the results.
Posted Jan 15, 2026 - 16:52 UTC

Investigating

We are investigating an issue with the web interface for Barracuda Backup Service. Users are unable to access device information globally.
Posted Jan 15, 2026 - 11:12 UTC
This incident affected: Backup Service (Web Interface).