Barracuda Cloud Archiving (BCAS) - Web 504 Gateway Time-out in the US, UK, and EU Regions

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Jan 30, 2025 - 20:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 30, 2025 - 15:53 UTC

Investigating

The US, UK, and EU Regions are experiencing 504 Gateway Time-Out errors when attempting to access the web interface. We have identified the issue and are working on a fix. Please note: Mail flow is NOT impacted.
Posted Jan 30, 2025 - 14:41 UTC
This incident affected: Cloud Archiving Service (Web Interface, End-user Access).