Mail processing delayed in US region

Incident Report for Barracuda Networks

Resolved

The engineering investigation is complete.  The incident was caused by a datacenter device failure which has been addressed.  Mail items which were deferred during the incident are now processed and available for search.
Posted Jul 02, 2026 - 15:11 UTC

Update

Mail processing service has been restored, but investigation is ongoing. We will provide further information as it becomes available.
Posted Jul 02, 2026 - 01:40 UTC

Investigating

The Barracuda Cloud Archiving Service is experiencing delayed mail processing for customers in the US region. All items are successfully received and stored, but new mail items may not be visible in search results. An engineering investigation is in progress & updates will follow as soon as information is available.
Posted Jul 01, 2026 - 23:40 UTC
This incident affected: Cloud Archiving Service (Mail Processing).