Barracuda XDR - Managed Endpoint Protection service disruption

Incident Report for Barracuda Networks

Resolved

SentinelOne has identified the issue, and implemented a solution. All affected agents are back online.
Please reach out to SOC (soc@barracuda.com) for any questions around the issue
Posted May 15, 2025 - 16:41 UTC

Investigating

We are aware of the connectivity issue between the SentinelOne agent and our management console and are currently working closely with SentinelOne's engineers to resolve it. In the meantime, the agent continues to provide protection on local endpoints.

We will update this status page once the issue has been resolved.

Thank You
Posted May 15, 2025 - 13:21 UTC
This incident affected: XDR (XDR Service).