Barracuda Incident Response - Service Degradation

Incident Report for Barracuda Networks

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 02, 2025 - 17:18 UTC

Investigating

We have identified an issue that is affecting Incident Response. We are working to resolve the issue. The ability to search for emails and create incidents may be affected by this issue.
Posted Oct 02, 2025 - 13:58 UTC
This incident affects: Incident Response (Email Processing).