Barracuda Cloud Archiving (BCAS) - Latency in US Region
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Sep 11, 2024 - 02:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2024 - 21:11 UTC
Update
We are working to resolve the issue. There are going to be message processing delays while we fix the problem. However, we will continue to receive messages. We appreciate your patience.
Posted Sep 10, 2024 - 18:08 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 10, 2024 - 16:25 UTC
This incident affected: Cloud Archiving Service (Web Interface, End-user Access, Mail Processing).