Barracuda Backup US Region Reporting Issue
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Dec 05, 2018 - 18:25 UTC
Investigating
The Barracuda Backup service is experiencing a reporting problem affecting the US region.
Posted Dec 05, 2018 - 06:04 UTC
This incident affected: Backup Service (Email Alerts / Reports).