UI performance degraded for Email Gateway Defense (UK region)
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Oct 21, 2024 - 13:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 17, 2024 - 12:33 UTC
Update
We are continuing to investigate this issue.
Posted Oct 17, 2024 - 12:33 UTC
Investigating
The user interface (UI) performance is degraded for some customers using Email Gateway Defense in the UK region. We are investigating the issue
Posted Oct 17, 2024 - 10:49 UTC
This incident affected: Email Gateway Defense (User Interface).