Barracuda Cloud Archiving System: Search Issues in All Regions

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 17:12 UTC

Identified

We have identified the issue that is affecting Search in the all regions and are working to resolve as quickly as possible. Search queries may continue to experience issues until resolved.
Posted Nov 12, 2025 - 15:17 UTC

Update

We have identified the issue that is affecting Search in the all regions and are working to resolve as quickly as possible. Search queries may continue to experience issues until resolved.
Posted Nov 12, 2025 - 15:16 UTC

Investigating

We are investigating an issue that is affecting Search in the all regions. Search queries may experience issues until resolved.
Posted Nov 12, 2025 - 14:56 UTC
This incident affected: Cloud Archiving Service (End-user Access).