The issue has been resolved. We are monitoring the system.
Posted Jul 16, 2025 - 15:05 UTC
Update
Mail flow has recovered and is back to normal in the UK, DE, CA, and AU regions. Capacity is back to normal for the US region, and deferral rates are improving. User interface accessibility may continue to be affected by this issue.
Posted Jul 16, 2025 - 14:51 UTC
Update
A fix has been implemented, and mail flow capacity is returning to normal levels.
Posted Jul 16, 2025 - 14:10 UTC
Identified
We have identified an issue impacting mail flow in the US, DE, CA, and AU regions. We are working to resolve the issue. User interface accessibility may also be affected by this issue.
Posted Jul 16, 2025 - 13:41 UTC
Update
We are continuing to investigate this issue.
Posted Jul 16, 2025 - 13:38 UTC
Investigating
We're investigating an issue impacting mailflow in multiple regions: US, DE, CA, AU.
Posted Jul 16, 2025 - 12:40 UTC
This incident affected: Email Gateway Defense (Mail Delivery, User Interface).