XDR Dashboard unavailable

Incident Report for Barracuda Networks

Resolved

This incident is resolved
Posted Sep 02, 2026 - 20:54 UTC

Monitoring

Logins and operation are currently restored and we will be monitoring to ensure root cause has been addressed.
Posted Sep 02, 2026 - 18:10 UTC

Update

We are investigating a login issue. The problem appears to be intermittent.
Posted Sep 02, 2026 - 17:44 UTC

Investigating

The team is investigating
Posted Sep 02, 2026 - 17:31 UTC
This incident affected: XDR (XDR Dashboard).