Barracuda Cloud Archiving (BCAS) - Hardware Outage - US Region

Incident Report for Barracuda Networks

Update

We are continuing to monitor for any further issues.
Posted May 13, 2026 - 14:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 12, 2026 - 18:41 UTC

Identified

PDUs (Power Distribution Units) went out in the US datacenter, causing a large number of RDX hosts to go offline. The vendor and our team are working to replace failed units as quickly as possible, however some customers may experience an inability to search and/or exports while the hardware is restored. There is no data loss associated with this incident.
Posted May 12, 2026 - 15:39 UTC
This incident affects: Cloud Archiving Service (Web Interface, End-user Access).