Barracuda Appliance Control: Service Disruption

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 05:14 UTC

Monitoring

The backup service is operational and we are monitoring the results.
Posted Jul 01, 2025 - 11:58 UTC

Identified

The backup service has been restored and is now operational.
Posted Jul 01, 2025 - 06:00 UTC

Investigating

Some customers may be experiencing issues with cloud backups failing due to the error: "File upload failed." We have implemented changes and are currently monitoring the situation. Our team is actively working to ensure the issue is fully resolved.
Posted Jun 30, 2025 - 16:39 UTC
This incident affected: Appliance Control (Cloud backups).