XDR dashboard does not load

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Feb 11, 2025 - 21:48 UTC

Monitoring

We have solved the problem and are monitoring to ensure it does not come back. If you have any additional issues, please reach out to Barracuda support.
Posted Feb 11, 2025 - 15:10 UTC

Investigating

Barracuda XDR is currently experiencing an issue with the dashboard. Our engineers are currently working to identify the cause and get our services back online. We understand this has an impact on your business, and we are working to get you up and running as quickly as possible.

The core XDR service is not affected. Data is still flowing into XDR and the SOC's systems are fully operational.

We will provide another update once the issue has been identified and we have started to implement a solution.
Posted Feb 11, 2025 - 14:37 UTC
This incident affected: XDR (XDR Dashboard).