Barracuda Cloud Archiving Service Disruption - UK Region
Incident Report for Barracuda Networks
Resolved
We have resolved this issue and all items have been archived. If you have any additional issues please reach out to our support team. We are sorry for the inconvenience and thank you for your patience while we worked on resolving it.
Posted Oct 28, 2021 - 15:55 UTC
Update
All Cloud Archiving Service customer emails from the period of this outage are now indexed and available for search.
Message Archive appliance customers using the hybrid option to archive their messages in the cloud may see some messages missing. We are continuing to make progress on indexing those items.
Posted Jul 23, 2021 - 23:38 UTC
Update
We have completed processing mail for Cloud Archiving Service customers and mail should be available for the affected time periods.

We are now working on indexing the mail from the Cloud Connected Appliance customers. We will provide an ETA for these customers as soon as it is available.
Posted Jul 21, 2021 - 15:26 UTC
Update
We have been able to successfully accelerate the indexing process to make them available for search. Affected messages have been queued for processing and no data has been lost. At the current rate we estimate that all items will be available by end of day Wednesday July 21. We will provide another update if the estimated completion date changes.
Posted Jul 19, 2021 - 20:54 UTC
Update
We're continuing to process items received between 2021-05-04 and 2021-05-14 from Cloud Archiving customers in the UK. We have recently made a change to help with better progress reporting of these items, and we're investigating further improvements to processing speed and reporting.
Posted Jul 16, 2021 - 20:23 UTC
Update
We're continuing to process items received between 2021-05-04 and 2021-05-14 from Cloud Archiving customers in the UK. We have recently made a change to help with better progress reporting of these items.
Posted Jul 15, 2021 - 18:51 UTC
Update
We're continuing to process items received between 2021-05-04 and 2021-05-14 from Cloud Archiving customers in the UK. We have recently made a change to help with better progress reporting of these items.
Posted Jul 12, 2021 - 22:31 UTC
Update
We're continuing to process items received between 2021-05-04 and 2021-05-14 from Cloud Archiving customers in the UK.
Posted Jul 09, 2021 - 23:42 UTC
Update
We're continuing to process items received between 2021-05-04 and 2021-05-14 from Cloud Archiving customers in the UK.
Posted Jun 23, 2021 - 18:53 UTC
Update
We're continuing to process items received between 2021-05-04 and 2021-05-14 from Cloud Archiving customers in the UK.
Posted Jun 14, 2021 - 20:49 UTC
Update
We're continuing to process items received between 2021-05-04 and 2021-05-14 from Cloud Archiving customers in the UK. We'll provide an ETA once it becomes available.
Posted Jun 07, 2021 - 15:15 UTC
Update
Some Cloud Archiving customers in the UK may experience delays in email archived between 2021-05-04 and 2021-05-14 appearing in search results. We are processing items received during that time period and will provide an ETA once it is available.
Posted Jun 02, 2021 - 15:44 UTC
Update
Some Cloud Archiving customers in the UK may experience delays in email archived between 2021-05-04 and 2021-05-14 appearing in search results. We are in the process of implementing the solution. We will provide an ETA once it is available.
Posted May 20, 2021 - 14:55 UTC
Identified
Some Cloud Archiving customers in the UK may experience delays in new archived email appearing in search results. We have identified the issue and are working to restore the service to normal operating levels.
Posted May 10, 2021 - 17:04 UTC
This incident affected: Cloud Archiving Service (Mail Processing).