Email Gateway Defense - Degraded mailflow performance in the US

Incident Report for Barracuda Networks

Resolved

This incident has been resolved. Mailflow and deferral rates are back to nominal levels.
Posted Nov 24, 2025 - 16:30 UTC

Monitoring

A fix has been implemented, and mailflow and deferral rates are recovering.
Posted Nov 24, 2025 - 15:08 UTC

Identified

We've identified a problem with US mailflow that is currently resulting in degraded performance. We have identified the problem and are working on a resolution.
Posted Nov 24, 2025 - 14:34 UTC
This incident affected: Email Gateway Defense (Mail Delivery).