Network Connectivity
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 17, 2018 - 08:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Oct 17, 2018 - 07:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Oct 17, 2018 - 06:01 UTC
Investigating
We are aware that some users may be experiencing connectivity issues and are investigating.
Posted about 1 month ago. Oct 17, 2018 - 05:13 UTC