Barracuda XDR - Log ingestion service disruption (Canada)

Incident Report for Barracuda Networks

Resolved

This incident has been resolved by the datalake vendor, and the impacted service is fully operational
Posted Apr 22, 2026 - 01:20 UTC

Monitoring

Our engineering team has worked with the datalake vendor to restore service in the Canada region, and the log ingestion service is now operating normally. We will continue to monitor the system closely to ensure it remains fully operational.
Posted Apr 21, 2026 - 21:22 UTC

Investigating

Barracuda XDR is currently experiencing an issue affecting the ingestion of logs into the XDR platform, which is impacting customers in the Canada region. Our engineering team is actively working with Databricks Support to investigate and resolve this matter. We acknowledge the potential impact on your business operations and want to assure you that we are fully committed to restoring full functionality as quickly as possible.
Further updates will be provided once the root cause has been identified. Thank you for your patience and understanding.
Posted Apr 21, 2026 - 20:56 UTC
This incident affected: XDR (XDR Service).