XDR Service Interruption

Incident Report for Barracuda Networks

Resolved

By monitoring over the weekend, we ensured that this issue has been resolved and the alerting process is resumed business-as-usual.
Posted Mar 31, 2025 - 13:08 UTC

Monitoring

Barracuda XDR was experiencing an issue in the alerting process around noon today, which resulted in triggering historic alerts of server security logs for handful of customers from our platform. Our engineers have identified the cause and implemented the fix to resolve this service issue. We will continue to monitor this process to ensure it is back to business-as-usual

The core XDR service is not affected. Data is still flowing into XDR and the SOC's systems are fully operational.
Posted Mar 28, 2025 - 18:17 UTC
This incident affected: XDR (XDR Service).