(BCAS) Global - Email Processing Delays

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted May 27, 2025 - 17:03 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 03, 2025 - 20:49 UTC

Investigating

BCAS experienced mail flow issues over the weekend, which may result in delays in message ingestion for some customers.
Posted May 03, 2025 - 20:49 UTC
This incident affected: Cloud Archiving Service (Mail Processing).