currently delays in UK mailflow
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Sep 25, 2020 - 15:10 UTC
Monitoring
Steps have been taken to remediate the delays seen in the region. We are monitoring the issue while the outstanding backlog is processed.
Posted Sep 25, 2020 - 13:24 UTC
Investigating
ESS is currently experiencing an issue with mail flow. Our engineers are currently working to identify the cause and get our services back online. We understand this has impacts on your business, we are working to get you up and running as fast as possible.

We will provide another update once the issue has been identified and we have started to implement a solution.
Posted Sep 25, 2020 - 12:24 UTC
This incident affected: Email Security Service (Mail Delivery, User Interface).