Network Connectivity to EMEA-UK Region for Barracuda Backup, CCB, MSP, Cloud Archiving, and Email Security
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jul 11, 2018 - 14:04 UTC
Monitoring
We have identified and fixed a problem within our network affecting these products. The issue should be resolving and we are monitoring for further problems.
Posted Jul 11, 2018 - 13:54 UTC
Investigating
We are currently investigating some network issues affecting our EMEA-UK region. It is impacting the Barracuda Backup, CCB, MSP, Cloud Archiving, and Email Security products in that region only.
Posted Jul 11, 2018 - 13:38 UTC
This incident affected: Cloud Archiving Service (Web Interface, End-user Access, Mail Processing, Exchange Integration, PST Import), Backup Service (Web Interface, Offsite Transfers), Message Archiver (Cloud Replication, Cloud Federated Search), Cloud to Cloud Backup (Office 365 Integration), Email Gateway Defense (Mail Delivery), and ECHOplatform.